Businesstipps Microsoft Office

So nutzen Sie den SVERWEIS bei der Suche nach exakten Werten

Lesezeit: 2 Minuten Der SVERWEIS ist eine nützliche Funktion, wenn man schnell aus einer großen Tabelle einen ganz bestimmten Wert auslesen oder weiterverwenden will. Dabei muss allerdings beachtet werden, dass der Suchbereich auf eine ganz bestimmte Weise aufgebaut ist. Aber es geht auch anders.

2 min Lesezeit

So nutzen Sie den SVERWEIS bei der Suche nach exakten Werten

Lesezeit: 2 Minuten

Nehmen wir an, Sie betreiben eine Handelsfirma und haben Ihr Angebot – also Artikel, Preise etc. in einer Excel-Tabelle abgelegt. Diese könnte im einfachsten Fall wie folgt aussehen, Spalte A enthält die Artikelbezeichnung, Spalte B den Verkaufspreis:

Zelle    Wert

A1       Artikel1

A2       Artikel2

A3       Artikel3

B1       100

B2       120

B3       150

Nehmen wir nun an, Sie möchten zu einem bestimmten Artikel den Preis heraussuchen, um damit z. B. ein Angebot zu verfassen. In C1 soll deshalb der Artikel eingetragen werden, in D1 über die Funktion SVERWEIS der zugehörige Preis ermittelt werden.

Die Funktion in D1 muss dann wie folgt aussehen: =SVERWEIS(C1;A1:B3;2;0).

In allgemeiner Form ist die Syntax SVERWEIS(Suchkriterium;Suchbereich;Spaltennummer der Zielspalte im Suchbereich;0).

Alternativ kann als 4. Argument statt 0 auch FALSCH eingegeben werden, für den einen oder anderen Anwender mag das übersichtlicher sein.

SVERWEIS bei der Suche nutzen

Wenn Sie jetzt diese Formel in D1 eintragen und C1 noch leer ist, erscheint in D1 eine Fehlermeldung #NV. Diese Fehlermeldung erscheint bei dieser Variante des SVERWEIS auch dann, wenn in C1 Werte eingetragen werden, die in Spalte A nicht vorkommen.

Diese Variante des SVERWEIS durchsucht die erste Spalte des Suchbereichs nach dem Suchkriterium und liefert den entsprechenden Wert aus der Spalte zurück, deren Nummer innerhalb des Suchbereichs als 3. Argument in die Funktion eingetragen wurde.

Anders als bei der anderen Variante des SVERWEIS (die ohne „;0“ als 4. Argument) bricht der SVERWEIS die Suche in der 1. Spalte des Suchbereichs nicht ab, sobald er einen Wert findet, der größer ist als das Suchkriterium: Die Funktion durchsucht immer den ganzen Suchbereich und liefert dann – wenn das Suchkriterium gefunden wurde (exakte Übereinstimmung!) den entsprechenden Wert zurück.

Es ist daher bei dieser Variante des SVERWEIS nicht notwendig, die Tabelle aufsteigend nach dem Suchkriterium zu sortieren – dafür sind aber auch keine Intervallzuordnungen möglich. Bitte probieren Sie es mit einer unsortierten Tabelle einfach aus. Sie werden sehen, dass die Funktion SVERWEIS immer noch den exakten Wert liefert.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: