Hobby & Freizeit Praxistipps

Wie Sie Listen per Formel nummerieren können

Listen in Excel zu nummerieren, unabhängig von der Zellposition, ist zum Beispiel dann praktisch, wenn die Nummerierung von Zeilen und Spalten unverändert beibehalten werden soll, auch wenn die Listenelemente sortiert oder gefiltert werden. Zeilen und Spalten auf diese Art nummerieren können Sie ganz leicht mit diesem kleinen Trick.

Wie Sie Listen per Formel nummerieren können

Um in Excel dergestalt zu nummerieren, stehen Ihnen die Funktionen "Zeile" und "Spalte" zur Verfügung. Für beide benötigen Sie als Argument nur einen Zellbezug, dann liefern die Funktionen die dementsprechenden Zeilen- und Spaltennummern als Ergebnis.
Möchten Sie Ihre Liste beginnend mit einem bestimmten Wert nummerieren, können Sie "Zeile" und "Spalte" ohne Probleme mit einer Addition oder Substraktion ergänzen. Soll Ihre Tabelle nicht auf einmal mit Inhalten gefüllt werden, können Sie sie so anlegen, dass die Nummerierung erst dann erfolgt, wenn Sie etwas in die jeweilige Zeile oder Spalte eingeben.
Dafür werden "Zeile" oder "Spalte" in eine Wenn-Abfrage integriert, bei der mit der Funktion "Ist leer" geprüft wird, ob in der Zelle bereits Inhalte vorhanden sind. Mit dieser Formel wird in Zelle A1 dann die Zeilennummer 1 eingefügt, wenn in B1 etwas eingetragen wird:
=WENN(ISTLEER(B1)"";ZEILE(B1))

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: