Computer Praxistipps

Wie Sie bei Excel benutzerdefinierte AutoFilter überlisten

Lesezeit: < 1 Minute Wenn Sie viel mit Listen arbeiten, werden Sie die AutoFilter zu schätzen wissen. Mit geschickter Vorbereitung in Verbindung mit einer Formel gelingt es Ihnen, die Liste in einer Spalte nach mehr als nur zwei Kriterien zu filtern. Oberhalb der Liste fügen Sie dafür eine kleine Tabelle ein, in die Sie die gewünschten Filterkriterien eingeben.

< 1 min Lesezeit

Wie Sie bei Excel benutzerdefinierte AutoFilter überlisten

Lesezeit: < 1 Minute
Die Größe dieser Tabelle richtet sich nach der maximalen Anzahl an Kriterien, mit Hilfe derer Sie filtern möchten. Als nächsten Schritt vergrößern Sie die Liste um eine zusätzliche Spalte, in die Sie folgende Formel eingeben, die auf die Tabelle mit Ihren Filterkriterien zugreift:
=WENN(ISTFEHLER(SVERWEIS(C9;$B$2:$B$6;1;0));"";"Filter ja")
Achten Sie darauf, beim Bezug auf die Filterkriterien ($B$3:$B$7) die Dollarzeichen einzugeben. Dadurch handelt es sich um einen absoluten Bezug und Sie stellen sicher, dass Sie die Formel für die restlichen Zellen kopieren können, ohne dass dieser Bezug verändert wird.

Nun zeigt die Formel für alle Zeilen Ihrer Liste, in denen in der Spalte "XY" einer der bei den Kriterien definierten X oder Y auftaucht. Bei Zeilen, die kein XY enthalten, bleibt die Spalte "Filter" leer.
Jetzt ist die Vorbereitung erledigt und Sie können letztendlich den AutoFilter einsetzen, um die Liste nach Ihren Kriterien zu filtern. Klicken Sie jetzt die AutoFilter-Liste für eine Spalte an, erscheinen dort nicht nur die Standardeinträge, sondern auch der Eintrag "Filter ja", den die Formel für einige Zeilen erzeugt hat. Wenn Sie diesen Eintrag anklicken, wird die Liste danach gefiltert.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: