Computer Praxistipps

Prüfen Sie mit der WENN-Funktion in 5 Schritten, ob Ihre Bedingung erfüllt wird

Kennen Sie Lügendetektoren aus Filmen? WENN der Befragte die Wahrheit sagt, dann kommt er frei, sonst muss er ins Gefängnis. Die WENN-Funktion ist so ein „Lügendetektor“, der in Tabellen die Wahrheit prüft und je nach Antwort eine passende Aktion durchführt!

Sie formulieren täglich solche Logikprüfungen im Alltag: WENN ich mindestens 50€ im Portmonee habe, dann lade ich dich zum Essen ins Lokal ein, sonst gehen wir zum Eisessen ins Café. WENN Sie diesen Satz verstehen, dann werden Sie auch die WENN-Funktion in Excel verstehen. Wir müssen ihn nur in die „Excel-Sprache“ übersetzen. Wie das geht, lesen Sie in diesem Beitrag.

So übersetzen Sie Ihre Anforderungen in die „Excel-Sprache“

Sie benötigen für jede Berechnung eine leere Zelle, in die Sie die Funktion eintragen können. Klicken Sie dazu in die leere Zelle, in der das Ergebnis stehen soll.

  1. Die WENN-Funktion beginnt mit einem Gleichheitszeichen, gefolgt von ihrem Namen WENN. Das sieht in Excel folgendermaßen aus: =WENN.
  2. Sie hat drei Argumente (Bestandteile), die durch ein Semikolon voneinander getrennt sind und von zwei Klammern umschlossen werden: =WENN(Prüfung;Dann;Sonst)
  3. Das erste Argument ist Ihre Frage, d.h. die Prüfung. Das muss eine Entscheidungsfrage sein, auf die es nur ein „Ja“ oder „Nein“ als Antwort gibt: =WENN (Prüfung;Wahr;Falsch)

Excel verwendet dafür die Begriffe wahr oder falsch.

In unserem Beispiel lautet die Prüfung: Sind mindestens 50 € im Portmonee? Zum Vergleichen benötigen Sie das Zeichen für größer gleich „>=“.

Der Geldbetrag ist in unserer Beispieldatei „WENN.xlsx“ in Zelle B2 notiert.

  1. Die Prüfung schreiben Sie so: B2>=50.
  2. Im zweiten Argument, dem Dann-Argument, legen Sie fest, was Excel machen soll, WENN die Antwort wahr lautet.

Im Beispiel ist es der Text: Ich lade ich dich zum Essen ins Lokal ein. Diesen Text müssen Sie in Anführungszeichen schreiben.

Für das dritte Argument bestimmen Sie, was Excel sonst machen soll. WENN wir nicht mindestens 50 € haben, kommt Excel zu der Antwort falsch. Für unser Beispiel bedeutet das: Wir gehen zum Eisessen ins Café. Der Beispielsatz sieht in die „Excel-Sprache“ übersetzt so aus: =WENN(B2>=50;“Lokal“;“Café“)

WENN-Funktion selbst schreiben – so geht’s

Schritt1: Zellcursor in die leere Ergebniszelle

Öffnen Sie die Beispieltabelle „WENN.xlsx“ und setzen Sie den Cursor in die Zelle C2.

Schritt 2: Gleichheitszeichen und WENN

Schreiben Sie das Gleichheitszeichen und dahinter WENN ohne Leerzeichen. Groß- oder Kleinschreiben ist möglich.

Excel hilft beim Tippen und schlägt die WENN-Funktion mit einem kurzen Hinweistext vor. Mit T (nicht M-Taste) wählen Sie WENN aus oder Sie klicken doppelt auf den blau hervorgehobenen WENN-Vorschlag.

Schritt 3: Die drei Argumente eintragen

Tragen Sie in das Feld Prüfung Ihre Frage ein: B2 mindestens 50, d. h., Sie tippen B2>=50. Setzen Sie nun ein Semikolon, um das zweite Argument, den „Dann“-Wert, einzugeben. Dazu schreiben Sie „Lokal“.

Denken Sie an die Anführungszeichen beim Eingeben dieses Werts, damit Excel ihn als Text erkennt. Setzen Sie wieder ein Semikolon. Zum Abschluss erfassen Sie den Sonst-Wert. Dazu schreiben Sie „Café„.

Schritt 4: Bestätigen

Werfen Sie einen Kontrollblick über die eben geschriebene Funktion.

Alles OK? Bestätigen Sie mit M oder klicken Sie auf das Häkchen-Icon in der Bearbeitungszeile.

Die abschließende Klammer fügt Excel selbst hinzu.

Das Ergebnis in Zelle C2 lautet Lokal. In der Bearbeitungszeile sehen Sie die WENN-Funktion, die das Ergebnis ermittelte.

Schritt 5: Ergebnis testen

Testen Sie, ob die WENN-Funktion auch bei einem Betrag von weniger als 50 € zum richtigen Ergebnis kommt. Dazu tragen Sie in die Zelle B2 den Wert 20 ein.

Fazit

Immer, wenn Sie Daten überprüfen möchten, wenden Sie ab sofort die WENN-Funktion an.

Mit dieser Funktion prüfen Sie Daten in Form von Werten, Texten und Formeln auf fast beliebige Bedingungen, um anschließend die gewünschten Aktionen durch Excel ausführen zu lassen. Herzlichen Glückwunsch: Mit der WENN-Funktion beherrschen Sie eine der wichtigsten Excel-Funktionen.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Dieser Artikel wurde noch nicht bewertet!
Please wait...

Über Ihren Experten

Burkhard Strack

Burkhard Strack ist Fachjournalist (DFJV-Mitglied) in den Ressorts Gesundheit, Finanzen und Marketing.