Businesstipps Microsoft Office

So sind bei Excel Berechnungen trotz Fehlermeldungen möglich

Lesezeit: < 1 Minute Es kann immer mal vorkommen, dass eine Formel bei Excel einen Fehler verursacht. Das Problem ist, dass alle Zellen, die sich auf diese Zelle beziehen, dann ebenfalls diesen Fehlerwert ausgeben. Mit einem kleinen Trick ist es jedoch möglich, diese Fehlerausgabe zu unterdrücken.

< 1 min Lesezeit

So sind bei Excel Berechnungen trotz Fehlermeldungen möglich

Lesezeit: < 1 Minute

Im Normalfall sieht es so aus: Wenn Sie wie in diesem Beispiel die Summe in der Zeile 7 bilden, dann erscheinen die entsprechenden Fehlermeldungen, die sich aus den oberen Zellen ergeben.

So sind bei Excel Berechnungen trotz Fehlermeldungen möglich  

Wenn Sie jedoch genau diese Fehlermeldung unterdrücken möchten, dann können Sie mit der folgenden Formel arbeiten

=Summe(WENN(ISTFEHLER(Bereich);0;Bereich))

Die SUMMEN-Funktion wird um eine Wenn- und eine ISTFEHLER-Funktion erweitert. Die ISTFEHLER-Funktion ermittelt, ob eine Zelle einen Fehler beinhaltet oder nicht. Die Wenn- Funktion gibt dann den Wert zurück, der entsprechend summiert werden soll.

In der Formel oben wird bei einem Fehler in der Zelle der Wert Null zurückgegeben. Dadurch kann Excel die Summierung fehlerfrei durchführen. Wichtig bei dieser Formel ist, dass es sich um eine Matrixformel handelt und diese Funktion nicht mit der ENTER-Taste bestätigt wird, sondern mit der Tastenkombination STRG + Shift + ENTER. Dadurch bekommt die Formel vorne und hinten geschweifte Klammern, dieses kennzeichnet eine Matrixformel.

Auf das obige Beispiel angewendet lautet die Formel in der Zelle A7

{=SUMME(WENN(ISTFEHLER(A1:A6);0;A1:A6))}

Und in der Zelle B7

{=SUMME(WENN(ISTFEHLER(B1:B6);0;B1:B6))}

 So sind bei Excel Berechnungen trotz Fehlermeldungen möglich

Es werden jetzt die richtigen Werte ermittelt.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: