Businesstipps Microsoft Office

Mit der Excel-Funktion „Summenprodukt“ Zeit sparen

Lesezeit: 2 Minuten In Excel gibt es eine Reihe von Funktionen, die man nur recht selten verwenden kann – aber wenn man sie mal nutzen kann, sind sie recht mächtige Werkzeuge. Zwar kann man vieles davon auch durch die üblichen Funktionen ersetzen, dies ist aber manchmal recht umständlich. Um eine dieser Funktionen – nämlich um das "Summenprodukt" – soll es an dieser Stelle gehen.

2 min Lesezeit

Mit der Excel-Funktion „Summenprodukt“ Zeit sparen

Lesezeit: 2 Minuten

Das Summenprodukt liefert für zwei Bereiche die Summe über alle Produkte der einzelnen Zeilen.

Um es an einem Beispiel deutlich zu machen:

Angenommen Sie bekommen Daten aus einer anderen Anwendung, beispielsweise aus einem Warenwirtschaftssystem. Für unser Beispiel hier soll dies eine Umsatzstatistik auf Artikelebene sein, bei der die Zugehörigkeit zu bestimmten Sortimenten / Sortimentsbereichen wie folgt gekennzeichnet sein soll:

Für den Bereich Food gibt es eine Spalte, in der mit einer 1 gekennzeichnet wird, ob ein Artikel zu diesem Sortiment gehört. Es gibt ebenso eine Spalte Non-Food und eine Spalte Service.

Als Tabelle könnte man sich das wie folgt vorstellen: Spalte A enthält
die Artikelbezeichnung, Spalte B die Kennzeichnung Food (mit 1 für Ja
und Leer für Nein), ebenso ist es in den Spalten C und D für Non-Food
und Service. In Spalte E sollen die Umsätze stehen.

Eine entsprechende Mustertabelle ist recht schnell erstellt:

Zelle    Wert

A1       Artikel1

A2       Artikel2

A3       Artikel3

A4       Artikel4

B1       1

B2

B3       1

B4

C1

C2       1

C3

C4

D1

D2

D3

D4       1

E1       100

E2       200

E3       300

E4       400

Will man nun in den Zellen F1, G1 und H1 die Umsatzsumme der Sortimentsbereiche ausweisen, könnte man dies mit "Summenprodukt" wie folgt machen:

F1:       =SUMMENPRODUKT(B1:B4;E1:E4)

G1:      =SUMMENPRODUKT(C1:C4;E1:E4)

H1:      =SUMMENPRODUKT(D1:D4;E1:E4)

Als Ergebnis werden 400 (aus den Zeilen 1 und 3), 200 (aus Zeile 2) und 400 (aus Zeile 4) angezeigt.

Um dies in einem solchen Fall so machen zu können, ist es natürlich zwingend notwendig, dass ein Faktor jeweils 1 ist und der andere jeweils 0. Sollten die Daten mal mit einer Kennzeichnung J / N oder mit Y / N o. ä. kommen, kann man natürlich über Suchen / Ersetzen recht schnell die notwendigen Spalteninhalte einfügen.

Denkbar wäre eine solche Lösung auch, wenn man eine Spalte mit Preisen und eine mit Mengen hat.

Eine elementare Lösung für eine solche Auswertung wäre ein Produkt für jede Spalte in jeder Zeile, in unserem Beispiel also 3 Produkte je Zeile (B1*E1, C1*E1 und D1*E1) und dann Summen über die Spalten. Falls die Spalten B-D andere Kennzeichnungen als 1/0 enthalten, müsste man wohl noch eine WENN davorschalten. Je nach Datenmenge kann eine solche Variante sehr tippaufwendig sein, man muss beim Kopieren und Einfügen auf relative und absolute Bezüge achten usw. – "Summenprodukt" ist also eine elegante und schnelle Lösung.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: