Businesstipps Microsoft Office

Excel: Zahlen variabel runden

Zahlen runden müssen Sie für kaufmännische Berechnungen oder Statistiken. Excel bietet mehrere Funktionen, die auf eine bestimmte Anzahl von Stellen runden. Leider zählt das Programm die Stellen von rechts aus, was sehr störend ist, wenn die Ausgangszahlen unterschiedlich groß sind.

Excel: Zahlen variabel runden

Um dreistellige Zahlen auf drei Dezimalstellen zu runden, reicht die Funktion aus. Fünf- oder sechsstellige Zahlen werden jedoch meist anders gerundet, und mit dieser Formel können Sie Zahlen größenabhängig runden:

=RUNDEN(Zahl;Links-1-GANZZAHL(LOG10(ABS(Zahl))))

Hiermit geben Sie an, auf welche Stelle Excel runden soll – und zwar von links aus. "Zahl" übergibt die Zahl, die gerundet werden soll, und mit dem Argument "Links" geben Sie an, auf wieviele Stellen von links aus gesehen Sie runden möchten. Wenn Sie also Ihre Zahl in A3 angeben, die Anzahl der Stellen in B3 und die gerundete Zahl in C3 erscheint, würde Ihre Formel so aussehen:

=RUNDEN(A3;B3-1-GANZZAHL(LOG10(ABS(A3)))).

Und so funktioniert die Formel zum variablen Runden

LOG10 ermittelt den Zehnerlogarithmus. Dieser entspricht der Anzahl der Stellen vor dem Komma weniger eins. Mit der Funktion ABS stellen Sie sicher, dass LOG10 auch bei negativen Zahlen funktioniert. RUNDEN rundet die Zahl. Als zweites Argument geben Sie RUNDEN die Dezimalstelle – von der rechten Seite aus gesehen -, auf die gerundet werden soll. Für diese Dezimalstelle geben Sie der Tabellenfuktion den Wert aus Spalte B weniger eins und des Ergebnisses von LOG10. Danach wird auf die gewünschte Position von links aus gerundet. Eine Position links vom Komma bekommt durch das zweite Argument einen negativen, die Position rechts des Kommas einen positiven Wert.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: