Businesstipps Microsoft Office

Excel Sverweis-Funktion: Mit einer Kombination aus Funktionen Komfort steigern

Lesezeit: < 1 Minute Wenn Sie mit der Sverweis-Funktion arbeiten, erscheint bei einem nicht gefundenen Wert der Eintrag "#NV". Es wäre aber eigentlich aussagekräftiger, wenn dann z. B. der Eintrag "Kein Wert vorhanden" kommt. Dies können Sie dadurch erreichen, dass Sie die Sverweis-Funktion mit der ISTFEHLER- und Wenn-Funktion verbinden.

< 1 min Lesezeit

Excel Sverweis-Funktion: Mit einer Kombination aus Funktionen Komfort steigern

Lesezeit: < 1 Minute

Die normale Sverweis-Funktion lautet in meinem Fall:

=(SVERWEIS(B2;B4:C6;2;0)

Da es sich bei dem Eintrag "#NV" um einen Fehler handelt, können Sie diesen mit der ISTFEHLER-Funktion abfragen.

Die Formel lautet:

=ISTFEHLER(SVERWEIS(B2;B4:C6;2;0))

Bei einem Fehler gibt die Funktion den Wert "Wahr" zurück. Diesen Wert kann ich dann mit einer Wenn-Funktion abfragen. Dazu setze ich einfach die Formeln ineinander.

Die fertige Formel zum Sverweis bei einem Fehler lautet:

=WENN(ISTFEHLER(SVERWEIS(B2;B4:C6;2;0));"Kein Wert vorhanden";SVERWEIS(B2;B4:C6;2;0))

Excel Sverweis-Funktion: Mit einer Kombination aus Funktionen Komfort steigern

Sie bedeutet, dass bei einem wahren Ergebnis bei der Prüfung der Text "Kein Wert vorhanden" kommt, ansonsten wird die Sverweis-Funktion ganz normal ausgeführt.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: