Businesstipps Microsoft Office

Excel: Minuszeichen von hinten nach vorn setzen

Lesezeit: < 1 Minute Wer Daten aus anderen Programmen oder von einem Großrechner bekommt, um sie mit Excel weiterzuverarbeiten, ist mitunter mit Minuszeichen konfrontiert, die nicht vor, sondern hinter der Zahl stehen. Das Problem ist nun, dass Excel derartig dargestellte Zahlen als Text interpretiert. Somit kann mit ihnen nicht gerechnet werden. Sie benötigen also eine Methode, das Minuszeichen von hinten nach vorn zu bekommen.

< 1 min Lesezeit

Excel: Minuszeichen von hinten nach vorn setzen

Lesezeit: < 1 Minute
Über einen Trick bekommen Sie es problemlos hin, das Minuszeichen mit einer Formel in einer anderen Zelle von hinten nach vorn zu setzen. Das können Sie natürlich auch in einer Hilfsspalte erledigen, die Sie nach der Umwandlung wieder löschen.
Stellen Sie sich vor, in der Zelle A1 steht eine Zahl mit einem Minuszeichen dahinter. Zur Umsetzung des Minuszeichens nach links geben Sie in die Zelle B1 folgende Formel ein:
=WENN(RECHTS(A1;1)="-"; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
Diese Formel überprüft, ob das erste Zeichen von rechts ein Minuszeichen ist. Wenn ja, wird der Zellinhalt bis auf das rechte Zeichen mit dem Wert -1 multipliziert. Das Ergebnis ist dann die gewünschte negative Zahl in der korrekten Form. Wenn die Überprüfung ergibt, dass das erste Zeichen von rechts kein Minuszeichen ist, liefert die Formel als Ergebnis einfach den Inhalt der Zelle A1.
Die Formel brauchen Sie nur in die erste Zelle, in unserem Beispiel B1, einzugeben. Anschließend kopieren Sie die Formel nach unten.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: