Businesstipps Microsoft Office

Excel-Hilfe: So nummerieren Sie Ihre Excellisten per Formel

Lesezeit: < 1 Minute Sie möchten Excel-Listen nummerieren und die Nummerierung von der Zellposition abhängig machen? Das bietet sich beispielsweise dann an, wenn Sie Zeilen oder Spalten so nummerieren möchten, dass die Zeilen- oder Spaltennummerierung unverändert erhalten bleibt, auch wenn die anderen Elemente der Liste sortiert oder gefiltert werden. Dabei ist Ihnen die die Tabellenfunktionen ZEILE und SPALTE eine Hilfe. Beide Funktionen benötigen als Argument lediglich einen Zellbezug. Als Ergebnis liefern die Funktionen dann die entsprechende Zeilen- beziehungsweise Spaltennummer.

< 1 min Lesezeit

Excel-Hilfe: So nummerieren Sie Ihre Excellisten per Formel

Lesezeit: < 1 Minute
Wenn Sie die Nummerierung einer Liste mit einem bestimmten Wert beginnen möchten, können Sie die Funktionen ZEILE und SPALTE problemlos mit einer Addition oder Subtraktion kombinieren.
 
Sofern Sie eine Tabelle erstellen, die erst nach und nach mit Inhalten gefüllt werden soll, können Sie diese so aufbauen, dass Nummerierungen erst dann vergeben werden, wenn Sie in die entsprechende Zeile oder Spalte etwas eingeben.

Dazu betten Sie die Funktion ZEILE oder SPALTE in eine Wenn-Abfrage ein, bei der Sie mit der Funktion ISTLEER überprüfen, ob eine Zelle bereits etwas enthält.

Die folgende Formel bewirkt in der Zelle A1, dass dort die Zeilennummer 1 erscheint, wenn in B1 etwas eingetragen wird, ansonsten bleibt sie leer: =WENN(ISTLEER(B1);"";ZEILE(B1)).

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: