Businesstipps Microsoft Office

Excel-Funktion SUMMEWENNS() nutzen

Lesezeit: < 1 Minute Diese Funktion ist sehr leistungsfähig und ermöglicht es, aus einem definierten Bereich, unter Angabe eines Suchkriteriums, aus einem Summenbereich gezielt Teilsummen zu bilden. Die Syntax lautet: = SUMMEWENN(Bereich;Suchkriterium;Summe_Bereich). Was aber, wenn Sie Summen bilden möchten, die mehrere Bedingungen erfüllen müssen?

< 1 min Lesezeit

Excel-Funktion SUMMEWENNS() nutzen

Lesezeit: < 1 Minute

Hier kommt als eine mögliche Lösung die Excel-Funktion SUMMEWENNS() in Spiel. Die Syntax lautet:
=SUMMEWENNS(Summebereich;Kriteriumbereich1;Kriterium1; Kriteriumbereich2;Kriterium2;…; Kriteriumbereich127;Kriterium127)

Wie aus der Syntax bereits erkennbar ist, können in dieser Funktion bis zu 127 Kriterien eingebaut werden. Ein Kriterium besteht jeweils aus einem Kriteriumbereich und einem Kriterium, also aus einem Pärchen. Das erste Argument, der Summebereich, bezieht sich auf eine Spalte bzw. Zeile.

Ein Beispiel:

Als Mitarbeiter einer Vertriebsabteilung möchten Sie die Verkaufsergebnisse in den Regionen Nord, Süd, Ost und West ermitteln. Sie haben zwei Außendienstmitarbeiter, die diese Bereiche gemeinsam "bearbeiten". Dabei möchten Sie analysieren, welchen Umsatz welcher Außendienstmitarbeiter in welcher Region erzielt hat.

Dazu habe ich folgende Tabelle aufgebaut (siehe Grafik):

In der Zelle B16 befindet sich folgende Funktion: =SUMME(B4:B15)

Die Zelle H5 ist mit dieser Funktion gefüllt: =SUMMEWENNS($B$4:$B$15;$D$4:$D$15;$F$5;$C$4:$C$15;G5)
Diese Funktion wird in die Zellen H6 bis H8 kopiert (bitte relative und absolute Bezüge – mit dem $-zeichen – beachten).

In der Zelle H9 wird eine Zwischensumme für den Außendienstmitarbeiter A gebildet. Dazu wird die Summenfunktion eingesetzt: =SUMME(H5:H8)

Weiterhin wird in die Zelle H10 folgende Funktion eingetragen:
=SUMMEWENNS($B$4:$B$15;$D$4:$D$15;$F$10;$C$4:$C$15;G10)
Auch diese Funktion wird kopiert in die Zellen H11 bis H13.

In der Zelle H14 wird ebenfalls eine Zwischensumme, allerdings für den Außendienstmitarbeiter B, gebildet. Die Summenfunktion lautet: =SUMME(H10:H13)

In der Zelle H16 wird die Summe aus H9 und H14 als Kontrollsumme zum Vergleich mit der B16 gebildet: =H9+H14

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: