Businesstipps Microsoft Office

Excel: Duplikate blitzschnell finden

Lesezeit: < 1 Minute Duplikate in Excel-Listen sind meist unerwünscht und ärgerlich. Das Überprüfen auf Duplikate kann langwierig sein - es sei denn, Sie verwenden eine Matrixformel, die Ihre Excel-Liste blitzschnell auf doppelte Einträge überprüft. Wir zeigen Ihnen, wie das geht.

< 1 min Lesezeit

Excel: Duplikate blitzschnell finden

Lesezeit: < 1 Minute

Tipp: Excel beherrschen – Im Nu lernen Sie das neue Excel kennen von den Grundlagen bis zu den
Profifunktionen.

Duplikate in Excel mit dieser Formel blitzschnell aufspüren
Wenn Sie Ihre Excel-Liste auf Duplikate überprüfen wollen, verwenden Sie diese Matrixformel:

=WENN(MAX(ZÄHLENWENN(Bereich;Bereich))>1;"Duplikate";"Keine Duplikate")

Mit "Bereich" übergeben Sie den Bereich, den Sie auf doppelte Einträge überprüfen möchten. Sie müssen die Formel, da es sich um eine Matrixformel handelt, mit einer Tastenkombination bestätigen:

Steuerung + Pfeil nach oben + Eingabe 

Excel: Duplikate finden – ein Beispiel
Die Formel gibt als Ergebnis "keine Duplikate" aus, wenn im übergebenen Bereich keine doppelten Einträge vorhanden sind. Als Ergebnis erscheint "Duplikat", wenn mindestens ein Eintrag doppelt erscheint.

So könnte die Formel aussehen, wenn Sie den Bereich A4 bis A 10 überprüfen wollen:

=WENN(MAX(ZÄHLENWENN(A4:A10;AA4:A10))>1;"Duplikate";"Keine Duplikate")

Duplikate in Excel aufspüren: So funktioniert die Formel
Mit ZÄHLENWENN wird der Inhalt jeder Zelle des Bereichs gezählt, wie oft er in dem Bereich auftritt. Das Ergebnis wird an die MAX-Funktion übergeben. Diese Funktion liefert den größten Wert unter den Ergebnissen von ZÄHLENWENN. Ergibt auch nur einer der Zählvorgänge einen Wert größer als eins, kommt mindestens ein Inhalt doppelt vor. Damit ist MAX >1, der Vergleich also wahr. Dann gibt die WENN-Funktion "Duplikate" aus.

Sind keine Dupliakte vorhanden, liefern alls Zählvorgänge den Wert eins, MAX ergibt auch eins, und der Vergleich mit ">1" ist falsch, so dass die WENN-Funktion den Text "Keine Duplikate" ausgibt.

Denken Sie daran, auch jede Änderung der Formel mit der Tastenkombination
Strg + Uparrow + Enter zu bestätigen.

PS: Qualitätsmanagement ist uns wichtig!

Bitte teilen Sie uns mit, wie Ihnen unser Beitrag gefällt. Klicken Sie hierzu auf die unten abgebildeten Sternchen (5 Sternchen = sehr gut):

Bitte warten...

PPS: Ihnen hat der Beitrag besonders gut gefallen?

Unterstützen Sie unser Ratgeberportal: